[{"name":"JSContact","comment":"\n\n@docs decoder, JSContact\n\n@docs Address, AddressComponent, AddressComponentKind, Addresses, Email, Emails, Kind, OnlineService, OnlineServices, Phone, Phones, PreferredLanguage, PreferredLanguages, RelatedTo, RelationType, UTCDateTime, Uid\n\n","unions":[{"name":"AddressComponentKind","comment":" The kind of the address component.\n","args":[],"cases":[["Room",[]],["Apartment",[]],["Floor",[]],["Building",[]],["StreetNumber",[]],["Name",[]],["Block",[]],["Subdistrict",[]],["District",[]],["Locality",[]],["Region",[]],["Postcode",[]],["Country",[]],["Direction",[]],["Landmark",[]],["PostOfficeBox",[]],["Separator",[]],["Other",["String.String"]]]},{"name":"Kind","comment":" The kind of the entity the Card represents\n","args":[],"cases":[["Individual",[]],["Group",[]],["Organization",[]],["Location",[]],["Device",[]],["Application",[]]]},{"name":"RelationType","comment":" The variants define the relation type between the two objects.\n","args":[],"cases":[["Aquaintance",[]],["Agent",[]],["Child",[]],["Coresident",[]],["Coworker",[]],["Colleague",[]],["Contact",[]],["Crush",[]],["Date",[]],["Emergency",[]],["Friend",[]],["Kin",[]],["Me",[]],["Met",[]],["Muse",[]],["Neighbor",[]],["Parent",[]],["Sibling",[]],["Spouse",[]],["Sweetheart",[]]]}],"aliases":[{"name":"Address","comment":" The address of the entity represented by the Card\n","args":[],"type":"{ contexts : List.List String.String, components : List.List JSContact.AddressComponent, isOrdered : Basics.Bool, countryCode : Maybe.Maybe String.String, coordinates : Maybe.Maybe String.String, timeZone : Maybe.Maybe String.String, full : Maybe.Maybe String.String, defaultSeparator : Maybe.Maybe String.String, pref : Maybe.Maybe Basics.Int, phoneticScript : Maybe.Maybe String.String, phoneticSystem : Maybe.Maybe String.String }"},{"name":"AddressComponent","comment":" The components that make up the address.\nThe component list MUST have at least one entry that has a kind property value other than \"separator\".\n","args":[],"type":"{ value : String.String, kind : JSContact.AddressComponentKind, phonetic : Maybe.Maybe String.String }"},{"name":"Addresses","comment":" This section defines properties for postal addresses and geographical\nlocations associated with the entity represented by the Card\n","args":[],"type":"Dict.Dict String.String JSContact.Address"},{"name":"Email","comment":" The email addresses in which to contact the entity represented by the Card.\n","args":[],"type":"{ contexts : List.List String.String, address : String.String, pref : Maybe.Maybe Basics.Int }"},{"name":"Emails","comment":" This section defines how properties contact the entity represented by the Card.\n","args":[],"type":"Dict.Dict String.String JSContact.Email"},{"name":"JSContact","comment":" The contact card.\n","args":[],"type":"{ kind : JSContact.Kind, version : String.String, uid : JSContact.Uid, created : Maybe.Maybe JSContact.UTCDateTime, updated : Maybe.Maybe JSContact.UTCDateTime, language : Maybe.Maybe String.String, members : List.List JSContact.Uid, prodId : Maybe.Maybe String.String, relatedTo : Maybe.Maybe JSContact.RelatedTo, emails : Maybe.Maybe JSContact.Emails, addresses : Maybe.Maybe JSContact.Addresses, phones : Maybe.Maybe JSContact.Phones, onlineServices : Maybe.Maybe JSContact.OnlineServices, preferredLanguages : Maybe.Maybe JSContact.PreferredLanguages }"},{"name":"OnlineService","comment":" The online services that are associated with the entity represented by the\nCard. This can be messaging services, social media profiles, and other.\n","args":[],"type":"{ service : Maybe.Maybe String.String, user : Maybe.Maybe String.String, uri : String.String, contexts : List.List String.String, pref : Maybe.Maybe Basics.Int }"},{"name":"OnlineServices","comment":" The online services in which to contact the entity represented by the Card\n","args":[],"type":"Dict.Dict String.String JSContact.OnlineService"},{"name":"Phone","comment":" A phone number by which to contact the entity represented by the Card\n","args":[],"type":"{ contexts : List.List String.String, phone : String.String, pref : Maybe.Maybe Basics.Int }"},{"name":"Phones","comment":" The phone numbers by which to contact the entity represented by the Card\n","args":[],"type":"Dict.Dict String.String JSContact.Phone"},{"name":"PreferredLanguage","comment":" A preferred language for contacting the entity associated with the Card\n","args":[],"type":"{ language : String.String, contexts : List.List String.String, pref : Maybe.Maybe Basics.Int }"},{"name":"PreferredLanguages","comment":" The preferred languages for contacting the entity associated with the Card.\n","args":[],"type":"Dict.Dict String.String JSContact.PreferredLanguage"},{"name":"RelatedTo","comment":" The set of Card objects that relate to the Card. The value is a map,\nwhere each key is the uid property value of the related Card,\nand the value defines the relation\n","args":[],"type":"Dict.Dict JSContact.Uid (List.List JSContact.RelationType)"},{"name":"UTCDateTime","comment":" The UTCDateTime type is a String in \"date-time\" format [RFC3339]\n","args":[],"type":"String.String"},{"name":"Uid","comment":" An identifier that associates the object as the same across different systems,\naddress books, and views. The value SHOULD be a URN [RFC8141],\nbut for compatibility with [RFC6350], it MAY also be a URI [RFC3986] or free-text value.\nThe value of the URN SHOULD be in the \"uuid\" namespace [RFC9562].\n[RFC9562] describes multiple versions of Universally Unique IDentifiers (UUIDs);\nUUID version 4 is RECOMMENDED.\n","args":[],"type":"String.String"}],"values":[{"name":"decoder","comment":" A JSON decoder for `JSContact`.\n","type":"Json.Decode.Decoder JSContact.JSContact"}],"binops":[]},{"name":"JSContact.Encoder","comment":"\n\n@docs encode\n\n","unions":[],"aliases":[],"values":[{"name":"encode","comment":" Encodes contact card to JSON.\n","type":"JSContact.JSContact -> Json.Encode.Value"}],"binops":[]}]