The contact card.
The address of the entity represented by the Card
The components that make up the address. The component list MUST have at least one entry that has a kind property value other than "separator".
The kind of the address component.
This section defines properties for postal addresses and geographical locations associated with the entity represented by the Card
The email addresses in which to contact the entity represented by the Card.
This section defines how properties contact the entity represented by the Card.
The kind of the entity the Card represents
The online services that are associated with the entity represented by the Card. This can be messaging services, social media profiles, and other.
The online services in which to contact the entity represented by the Card
A phone number by which to contact the entity represented by the Card
The phone numbers by which to contact the entity represented by the Card
A preferred language for contacting the entity associated with the Card
The preferred languages for contacting the entity associated with the Card.
The set of Card objects that relate to the Card. The value is a map, where each key is the uid property value of the related Card, and the value defines the relation
The variants define the relation type between the two objects.
The UTCDateTime type is a String in "date-time" format [RFC3339]
An identifier that associates the object as the same across different systems, address books, and views. The value SHOULD be a URN [RFC8141], but for compatibility with [RFC6350], it MAY also be a URI [RFC3986] or free-text value. The value of the URN SHOULD be in the "uuid" namespace [RFC9562]. [RFC9562] describes multiple versions of Universally Unique IDentifiers (UUIDs); UUID version 4 is RECOMMENDED.
A Name object as defined in RFC 9553.
A NameComponent object as defined in RFC 9553.
The kind of the name component.
A JSON decoder for
JSContact.